STATIC ROUTING - Al-Muhibbin Indonesia

Al-Muhibbin Indonesia

Berbagi ilmu melalui catatan kuliah, catatan kerja dan Kajian Islam Ahlussunah Waljamaah.

Breaking

Rabu, 02 Februari 2011

STATIC ROUTING

MENGENAL JENIS ROUTING PROTOKOL DAN IMPLEMENTASINYA



Sebenarnya apa sih Roting Protokol, kegunaannya dalam kehidupan Network sehari-hari..?
Itu pertama kali yang  muncul di otak pertama kali belajar network, jaringan terutama pasa praktikum Jaringan Komputer di Kampus dulu. Sebenarnya routing protocol adalah suatu aturan baku yang dikhususkan untuk perutean jalur dari suatu network ke network yang lain. Kalo dibuat simpelnya seperti rambu-rambu lalu lintas.


Macam macam routing protocol sangat beragam, dan mempunyai fungsi dan implementasi yang beragam : 

STATIC ROUTING

Menambahkan Routing Statik

Routing statik sebenarnya paling mudah di implementasikan karena ditambahkan secara manual oleh administrator dan sifatnya tetap biasanya diperuntukkan untuk jaringan dengan kapasitas kecil, semacam lab sekolah atau lab kampus.

Aturan bakunya untuk konfigurasinya adalah:

Router(config)# ip route [destination network/destination ip address] [next hop ip address/forwarding interface] [administrative distance]

RouterD(config)# ip route 172.32.3.0 255.255.255.0 172.32.2.2

Cara kerja routing statik
Administrator jaringan mengkonfigurasi router secara manual, router melakukan routing berdasarkan informasi dalam table routing, kemudian routing static tadi digunakan untuk melewatkan paket data

Keuntungan 
Statik routing lebih aman dibandingkan dengan routing dinamis dikarenakan alamat ip yang kita routingkan pasti, sehingga sedikit lebih aman dari ancaman spoofing di jaringan.

Kerugian 
Konfigurasinya cukup lama dan rumit, apalagi jika router nya banyak, di samping itu juga rentan kesalahan dalam memasukan alamat IP di router yang kita konfigurasi, jika salah, ya pasti jaringan tidak bisa konek.

Merubah administrative distance
Administrative Distance diperlukan dalam routing static untuk memastikan konfigurasi dibaca oleh network lain jika kondisinya dalam jaringan itu ada forwarding interface dan next hop ip address.

Secara Default administrative distance dari routing static adalah:
- 0 jika forwarding interface terkonfigurasi
- 1 jika next hop ip address terkonfigurasi


lustrasi Routing Statik


Contoh Konfigurasi di Routernya via Packet Tracer


Contoh Konfigurasi di Routernya via IOS Cisco

========================
Router I
========================
Router>enable 
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname sterling
sterling(config)#interface FastEthernet0/0
sterling(config-if)#ip address 172.16.1.1 255.255.255.0
sterling(config-if)#no shutdown 


%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
sterling(config-if)#exit
sterling(config)#
sterling(config)#interface FastEthernet0/0
sterling(config-if)#
sterling(config-if)#exit
sterling(config)#interface Serial2/0
sterling(config-if)#ip address 172.16.2.1 255.255.255.0
sterling(config-if)#clock rate 56000
sterling(config-if)#no shutdown 


%LINK-5-CHANGED: Interface Serial2/0, changed state to down
sterling(config-if)#exit
sterling(config)#


=============================
Router II
=============================
Router>enable 
Router#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname hobooken
hobooken(config)#interface Serial2/0
hobooken(config-if)#ip address 172.16.2.2 255.255.255.0
hobooken(config-if)#clock rate 56000
hobooken(config-if)#no shutdown 
hobooken(config-if)#
hobooken(config-if)#exit
hobooken(config)#interface FastEthernet0/0
hobooken(config-if)#ip address 172.16.3.1 255.255.255.0
hobooken(config-if)#no shutdown
hobooken(config-if)#exit
hobooken(config)#interface Serial3/0
hobooken(config-if)#ip address 172.16.4.1 255.255.255.0
hobooken(config-if)#clock rate 56000
hobooken(config-if)#no shutdown 


%LINK-5-CHANGED: Interface Serial3/0, changed state to down
hobooken(config-if)#


=======================
Router III
=======================
Router>enable 
Waycross#configure terminal 
Router(config)#hostname Waycross
Enter configuration commands, one per line.  End with CNTL/Z.
Waycross(config)#interface Serial2/0
Waycross(config-if)#ip address 172.16.4.2 255.255.255.0
Waycross(config-if)#clock rate 56000
Waycross(config-if)#no shutdown 


%LINK-5-CHANGED: Interface Serial2/0, changed state to up
Router(config-if)#exit
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
Waycross(config)#interface FastEthernet0/0
Waycross(config-if)#ip address 172.16.5.1 255.255.255.0
Waycross(config-if)#no shutdown 


%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Waycross(config-if)#exit
Waycross(config)#ip route 172.16.3.0 255.255.255.0 172.16.4.1
Waycross(config)#


================================
SETING STATIC ROUTING
================================
sterling(config)#ip route 172.16.3.0 255.255.255.0 172.16.2.2
hobooken(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.1
hobooken(config)#ip route 172.16.5.0 255.255.255.0 172.16.4.2
Waycross(config)#ip route 172.16.3.0 255.255.255.0 172.16.4.1


=================================
LIHAT HASILNYA
=================================
hobooken#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route


Gateway of last resort is not set


     172.16.0.0/24 is subnetted, 5 subnets
S       172.16.1.0 [1/0] via 172.16.2.1
C       172.16.2.0 is directly connected, Serial2/0
C       172.16.3.0 is directly connected, FastEthernet0/0
C       172.16.4.0 is directly connected, Serial3/0
S       172.16.5.0 [1/0] via 172.16.4.2


Waycross#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route


Gateway of last resort is not set


     172.16.0.0/24 is subnetted, 3 subnets
S       172.16.3.0 [1/0] via 172.16.4.1
C       172.16.4.0 is directly connected, Serial2/0
C       172.16.5.0 is directly connected, FastEthernet0/0
Waycross#


sterling#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route


Gateway of last resort is not set


     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
C       172.16.2.0 is directly connected, Serial2/0
S       172.16.3.0 [1/0] via 172.16.2.2
sterling#



Tidak ada komentar:

Posting Komentar