Routing Information Protocol (RIP)


Routing Information Protocol

Routing Information Protocol atau yang dikenal RIP adalah dinamik routing protokol yang sudah cukup tua. Diciptakan sekitar tahun 1970. Cara kerjanya berdasarkan Distance Vector Routing Protocol, yang berarti akan mempergunakan pendekatan berapa banyak hop (lompatan) router yang akan ditempuh untuk mencapai suatu network.
RIP yang cara kerjanya berdasarkan Distance Vector Routing Protocol memiliki kelemahan yang dapat terlihat apabila dalam jaringan ada link yang terputus. Dua kemungkinan kegagalan yang mungkin terjadi adalah efek bouncing dan menghitung-sampai-tak-hingga (counting to infinity). Efek bouncing dapat terjadi pada jaringan yang menggunakan metrik yang berbeda pada minimal sebuah link. Link yang putus dapat menyebabkan routing loop, sehingga datagram yang melewati link tertentu hanya berputar-putar di antara dua router (bouncing) sampai umur (time to live) datagram tersebut habis. Menghitung-sampai-tak hingga terjadi karena router terlambat menginformasikan bahwa suatu link terputus.

Keterlambatan ini menyebabkan router harus mengirim dan menerima distance-vector serta menghitung metrik sampai batas maksimum metrik distance-vector tercapai. Link tersebut dinyatakan putus setelah distance-vector mencapai batas maksimum metrik. Pada saat menghitung metrik ini juga terjadi routing loop, bahkan untuk waktu yang lebih lama daripada apabila terjadi efek bouncing.
RIP menggunakan metode Triggered Update. RIP memiliki timer untuk mengetahui kapan router harus kembali memberikan informasi routing. Jika terjadi perubahan pada jaringan, sementara timer belum habis, router tetap harus mengirimkan informasi routing karena dipicu oleh perubahan tersebut (triggered update). Dengan demikian, router-router di jaringan dapat dengan cepat mengetahui perubahan yang terjadi dan meminimalkan kemungkinan routing loop terjadi.
RIP mengirim routing table yang lengkap ke semua interface yang aktif setiap 30 detik. atau lebih cepat jika terdapat triggered updates. Jika dalam 180 detik sebuah route tidak diperbarui, router menghapus entri route tersebut dari forwarding table. RIP tidak memiliki informasi tentang subnet setiap route. Router harus menganggap setiap route yang diterima memiliki subnet yang sama dengan subnet pada router itu. Dengan demikian, RIP tidak mendukung Variable Length Subnet Masking (VLSM). RIP hanya menggunakan jumlah hop untuk menentukan cara terbaik ke sebuah network remote, tetapi RIP secara default memiliki sebuah nilai jumlah hop maksimum yg diizinkan, yaitu 15, berarti nilai 16 tidak terjangkau (unreachable). RIP bekerja baik pada jaringan kecil, tetapi RIP tidak efisien pada jaringan besar dengan link WAN atau jaringan yang menggunakan banyak router.

RIP versi 2 (RIP-2 atau RIPv2) berupaya untuk menghasilkan beberapa perbaikan atas RIP, yaitu dukungan untuk VLSM, menggunakan otentikasi, memberikan informasi hop berikut (next hop), dan multicast. Penambahan informasi subnet mask pada setiap route membuat router tidak harus mengasumsikan bahwa route tersebut memiliki subnet mask yang sama dengan subnet mask yang digunakan padanya


Kalau kita rangkum RIP punya beberapa sifat dominan atau karakter
  1.  Termasuk Distance-vector routing protocol
  2. Maximum hop count nya 15
  3. 16 hop artinya sudah tak terjangkau dalam hitungan metrik 
  4. Hop count adalah metric yang tersedia pada jalur yang ada
  5. Sifatnya Broadcast routing table yang masuk ke neighbour / tetangganya setiap 30 menit
  6. Bisa digunakan untuk keperluan balancing
  7. Mudah di konfigurasi

Contoh Kasus Implementasi RIP


=======================
ROUTER I
=======================
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Bandung
Bandung(config)#interface fastEthernet 0/0
Bandung(config-if)#ip address 172.16.1.1 255.255.255.0
Bandung(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Bandung(config-if)#exit
Bandung(config)#interface serial 2/0
Bandung(config-if)#ip address 172.16.2.1 255.255.255.0
Bandung(config-if)#clock rate 56000
Bandung(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Bandung(config-if)#exit
Bandung(config)


==========================
router 2
==========================
Router>ena
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Jakarta
Jakarta(config)#interface serial 2/0
Jakarta(config-if)#ip address 172.16.2.2 255.255.255.0
Jakarta(config-if)#clock rate 56000
Jakarta(config-if)#no shutdown


%LINK-5-CHANGED: Interface Serial2/0, changed state to up
Jakarta(config-if)#exit
Jakarta(config)#interface fastEthernet 0/0
Jakarta(config-if)#ip address 172.16.3.1 255.255.255.0
Jakarta(config-if)#exit
Jakarta(config)#interface serial 3/0
Jakarta(config-if)#ip address 172.16.4.1 255.255.255.0
Jakarta(config-if)#clock rate 56000
Jakarta(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Jakarta(config-if)#exit
Jakarta(config)#interface fastEthernet 0/0
Jakarta(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Jakarta(config-if)#exit
Jakarta(config)#
================
router 3

Router>ena
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Surabaya
Surabaya(config)#interface serial 2/0
Surabaya(config-if)#ip address 172.16.4.2 255.255.255.0
Surabaya(config-if)#clock rate 56000
Surabaya(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to up
Surabaya(config-if)#exit
Surabaya(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up


Surabaya(config)#interface fastEthernet 0/0
Surabaya(config-if)#ip address 172.16.5.1 255.255.255.0
Surabaya(config-if)#no shutdown

Surabaya(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Surabaya(config-if)#exit
Surabaya(config)#
Surabaya#

======================
RIP KONFIGURASI
======================

Bandung(config)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
Bandung(config)#router rip
Bandung(config-router)#network 172.16.1.0
Bandung(config-router)#network 172.16.2.0
Bandung(config-router)#exit

Jakarta(config)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up
Jakarta(config)#router rip
Jakarta(config-router)#network 172.16.2.0
Jakarta(config-router)#network 172.16.3.0
Jakarta(config-router)#network 172.16.4.0
Jakarta(config-router)#exit
Jakarta(config)#





Enter configuration commands, one per line.  End with CNTL/Z.
Surabaya(config)#router rip
Surabaya(config-router)#network 172.16.4.0
Surabaya(config-router)#network 172.16.5.0
Surabaya(config-router)#exit
Surabaya(config)#

====================
LIHAT HASILNYA
=============
Bandung>enable
Bandung#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 5 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
C       172.16.2.0 is directly connected, Serial2/0
R       172.16.3.0 [120/1] via 172.16.2.2, 00:00:09, Serial2/0
R       172.16.4.0 [120/1] via 172.16.2.2, 00:00:09, Serial2/0
R       172.16.5.0 [120/2] via 172.16.2.2, 00:00:09, Serial2/0


Jakarta>enable
Jakarta#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 5 subnets
R       172.16.1.0 [120/1] via 172.16.2.1, 00:00:09, Serial2/0
C       172.16.2.0 is directly connected, Serial2/0
C       172.16.3.0 is directly connected, FastEthernet0/0
C       172.16.4.0 is directly connected, Serial3/0
R       172.16.5.0 [120/1] via 172.16.4.2, 00:00:14, Serial3/0
Jakarta#

Surabaya>enable
Surabaya#sho ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 5 subnets
R       172.16.1.0 [120/2] via 172.16.4.1, 00:00:08, Serial2/0
R       172.16.2.0 [120/1] via 172.16.4.1, 00:00:08, Serial2/0
R       172.16.3.0 [120/1] via 172.16.4.1, 00:00:08, Serial2/0
C       172.16.4.0 is directly connected, Serial2/0
C       172.16.5.0 is directly connected, FastEthernet0/0
Surabaya#


Share:

0 comments