"ip ospf mtu-ignore" pada protocol ospf



Barusan ada case mirip dengan artikel di bawah ini cabang Jasa Marga Medan OSPF belum mau naik dari sisi Provider, namun dari sisi JM sudah naik, walhasil kadang ospf nya tidak stabil. Padahal sudah di solusikan dengan mengganti perangkat DSLAM yang support OSPF, clear ospf dan lain sebagainya. Kami coba cari solusi bagaimana mulai dari menyamakan konfig CE dan PE sampai ketemu solusi ini ip ospf mtu-ignore.  Sangat bermanfaat, dan satu lagi learning by doing dan jangan males bertanya.

================= |||||| =========================

Berikut bahasan lengkapnya dari  web sodara Dony Ramansyah :) 

================= |||||| =========================

Sedikit share mengenai pengalaman saja, dimana ketika membuat sebuah koneksi dengan protocol OSPF. tidak mau UP juga protocol OSPF nya, padahal semua konfigurasi OSPF sudah benar.

Contoh saja konfigurasi berikut :
=================================


Router 6 Configuration :

interface Serial2

!--- MTU sets to it's default value of 1500.

no ip address
no ip directed-broadcast
encapsulation frame-relay
no ip mroute-cache
frame-relay lmi-type ansi
!
interface Serial2.7 point-to-point
ip address 170.170.11.6 255.255.255.0
no ip directed-broadcast
frame-relay interface-dlci 101
!
router ospf 7
redistribute static subnets
network 170.170.11.0 0.0.0.255 area 0


Router 7 Configuration :

!
interface Serial0
mtu 1450
no ip address
no ip directed-broadcast
encapsulation frame-relay
frame-relay lmi-type ANSI

!
interface Serial0.6 point-to-point
ip address 170.170.11.7 255.255.255.0
no ip directed-broadcast
frame-relay interface-dlci 110!
!

router ospf 7
network 170.170.11.0 0.0.0.255 area 0

ip route 192.79.34.0 255.255.255.0 Null0
ip route 192.79.35.0 255.255.255.0 Null0
ip route 192.79.36.0 255.255.255.0 Null0
ip route 192.79.37.0 255.255.255.0 Null0
ip route 192.79.38.0 255.255.255.0 Null0


Ketika dilihat output hasil OSPFnya :

router-6# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
170.170.11.7 1 EXCHANGE/ - 00:00:36 170.170.11.7 Serial2.7
router-6#

router-7# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
170.170.11.6 1 EXSTART/ - 00:00:33 170.170.11.6 Serial0.6
router-7#

Untuk mengetahui detail permasalahan yang terjadi, kita bisa jalankan command "debug ip ospf" dan mengecek hasil debugnya.

Karena Router 6 memiliki MTU lebih tinggi, ia terus menerima paket dari Router DBD 7, mencoba untuk mengenali lawannya, dan akan tetap berada di status EXCHANGE.

Karena Router 7 telah MTU yang lebih rendah, ia mengabaikan DBD bersama dengan paket ACK dari Router 6, terus retransmit awal DBD paket, dan tetap di status EXSTART.

Marilah kita melihat beberapa langkah-langkah di atas. Pada hasil debug Router, Router 6 DBD pertama mereka mengirim paket dengan flag 0x7 ditetapkan sebagai bagian dari Master / slave. Setelah Master / slave ditentukan, Router 7 dipilih sebagai Master karena ia lebih tinggi dilihat dari Router-ID nya. Menunjukkan bahwa Router 7 adalah Master (flag 0x7) dan 6 adalah slave Router (flag 0x2).

Selanjutnya Router 6 menerima Router 7 awal DBD paket dan transisi ke statusnya 2-way. Router Router 7 menerima Router 6 awal packet DBD MTU dan akan mengenali mismatch. (7 Router mampu mengenali sebuah MTU mismatch karena Router 6 termasuk interface MTU-nya dari paket DBD). Router 6 awal yang ditolak oleh DBD Router 7. Router 7 retransmits awal DBD paket.

Router 6, sebagai slave, mengirimkan paket yang berisi header dari LSAs, yang akan meningkatkan ukuran paket. Namun, Router 7 DBD ini tidak pernah menerima paket karena lebih besar daripada MTU pada Router 7.

Kemudian Router 7 terus retransmit awal DBD paket ke Router 6, sedangkan Router 6 terus mengirimkan paket DBD yang mengikuti master urutan nomor. Lingkaran ini terus tanpa batas, yang mencegah salah satu router dari transisi dari status exstart / saling tukar.

Solusinya :

Pada IOS Cisco 12.01(3) dikenalkanlah command "ip ospf mtu-ignore", yang dipasang pada kedua interface back to back (b2b) kedua router tersebut. Dengan commmand tersebut maka protocol OSPF akan mengabaikan besaran MTU dikedua interface back to back tersebut.

Untuk lebih detal silahkan buka link berikut :http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080093f0d.shtml


Dony Ramansyah
site : http://dony-ramansyah.bravehost.com
blog : dony-ramansyah.blogspot.com
email : dony.ramansyah[at]gmail.com
Registered linux user : ID 400171

Share:

0 comments